Rename issue with <year> = 0

Get help with Couchpotato
houndtt
Junior Member
Posts: 6
Joined: 05 Dec 2016 05:23
Status: Offline

Rename issue with <year> = 0

Postby houndtt » 06 Jul 2017 04:37

Recently many of the movies I download have a problem using the <year> option for both the folder and the file. My current renamer configuration is as follows:

Folder naming: <year>/<namethe> (<quality>)
File naming: <thename><cd_nr> (<year>).<ext>

This was working well for quite some time but of late a bunch of the year attributes have the value 0. As such, I have to rename a number of files and manually re-file the movie after it is downloaded. Here is a sample of the renaming issues:

Code: Select all

07-01 16:46:42 INFO
[tato.core.plugins.renamer] Moving "/volume1/downloads/complete/Movies/The.Lost.City.of.Z.2016.720p.BluRay.x264-GECKOS.cp(tt1212428)/The.Lost.City.of.Z.2016.720p.BluRay.x264-GECKOS.sub" to "/volume1/video/Movies (HD)/0/Lost City of Z, The (720p)/The Lost City of Z (0).en.sub"
07-01 16:46:42 INFO
[tato.core.plugins.renamer] Moving "/volume1/downloads/complete/Movies/The.Lost.City.of.Z.2016.720p.BluRay.x264-GECKOS.cp(tt1212428)/The.Lost.City.of.Z.2016.720p.BluRay.x264-GECKOS.mkv" to "/volume1/video/Movies (HD)/0/Lost City of Z, The (720p)/The Lost City of Z (0).mkv"
07-01 16:47:56 INFO
[tato.core.plugins.renamer] Moving "/volume1/downloads/complete/Movies/The.Lost.City.of.Z.2016.720p.BluRay.x264-GECKOS.cp(tt1212428)/The.Lost.City.of.Z.2016.720p.BluRay.x264-GECKOS.idx" to "/volume1/video/Movies (HD)/0/Lost City of Z, The (720p)/The Lost City of Z (0).idx"


Code: Select all

06-29 00:45:20 INFO
[tato.core.plugins.renamer] Moving "/volume1/downloads/complete/Movies/T2.Trainspotting.2017.720p.BluRay.DTS.x264-FuzerHD.cp(tt2763304)/T2.Trainspotting.2017.720p.BluRay.DTS.x264-FuzerHD.mkv" to "/volume1/video/Movies (HD)/0/T2 Trainspotting (720p)/T2 Trainspotting (0).mkv"


As you can see this happens for a number of different movies and in different years. Looking at the logs I see that within the same timeframe there have also been successful renames such as this one:

Code: Select all

06-30 07:30:18 INFO
[tato.core.plugins.renamer] Moving "/volume1/downloads/complete/Movies/The.Fate.of.the.Furious.2017.720p.BluRay.x264-SPARKS.cp(tt4630562)/The.Fate.of.the.Furious.2017.720p.BluRay.x264-SPARKS.mkv" to "/volume1/video/Movies (HD)/2017/Fate of the Furious, The (720p)/The Fate of the Furious (2017).mkv"
06-30 07:31:22 INFO
[tato.core.plugins.renamer] Moving "/volume1/downloads/complete/Movies/The.Fate.of.the.Furious.2017.720p.BluRay.x264-SPARKS.cp(tt4630562)/the.fate.of.the.furious.2017.720p.bluray.x264-sparks.nfo" to "/volume1/video/Movies (HD)/2017/Fate of the Furious, The (720p)/The Fate of the Furious (2017).orig.nfo"
06-30 07:31:22 INFO
[tato.core.plugins.renamer] Moving "/volume1/downloads/complete/Movies/The.Fate.of.the.Furious.2017.720p.BluRay.x264-SPARKS.cp(tt4630562)/The.Fate.of.the.Furious.2017.720p.BluRay.x264-SPARKS.sub" to "/volume1/video/Movies (HD)/2017/Fate of the Furious, The (720p)/The Fate of the Furious (2017).en.sub"
06-30 07:31:22 INFO
[tato.core.plugins.renamer] Moving "/volume1/downloads/complete/Movies/The.Fate.of.the.Furious.2017.720p.BluRay.x264-SPARKS.cp(tt4630562)/The.Fate.of.the.Furious.2017.720p.BluRay.x264-SPARKS.idx" to "/volume1/video/Movies (HD)/2017/Fate of the Furious, The (720p)/The Fate of the Furious (2017).idx"


I can't seem to ascertain a pattern nor identify any recent automatic upgrades to Couch Potato Server which would have caused this. Any assistance in resolving same would be appreciated.

Update: I see that I should be posting with some debug logs attached to the issue so I went ahead and reproduced it again and the debug log can be found here: https://pastebin.com/XgLYhBXu.

User avatar
clinton.hall
Moderator
Posts: 9224
Joined: 28 Jun 2012 12:55
Has thanked: 94 times
Been thanked: 465 times
Contact:
Status: Offline

Re: Rename issue with <year> = 0

Postby clinton.hall » 21 Jul 2017 13:33

what version of CouchPotato are you running? there was a problem with retrieving the year data, but this was fixes some time ago in source.

megapearl
Junior Member
Posts: 2
Joined: 30 Jul 2017 13:53
Location: Den Helder
Contact:
Status: Offline

Re: Rename issue with <year> = 0

Postby megapearl » 30 Jul 2017 13:59

I Still having this issue too... about half an year now.

I'm running Version 0a97ed5a (6/26/2017, 1:29:35 PM) on FreeBSD 11
What to do? how to debug?

clowg
Junior Member
Posts: 13
Joined: 04 Jul 2013 05:28
Status: Offline

Re: Rename issue with <year> = 0

Postby clowg » 30 Jul 2017 14:13

I've also been having this issue for several months. I'm using version 3.01 on Windows.

megapearl
Junior Member
Posts: 2
Joined: 30 Jul 2017 13:53
Location: Den Helder
Contact:
Status: Offline

Re: Rename issue with <year> = 0

Postby megapearl » 31 Aug 2017 16:58

Is there any progress on this issue?

houndtt
Junior Member
Posts: 6
Joined: 05 Dec 2016 05:23
Status: Offline

Re: Rename issue with <year> = 0

Postby houndtt » 13 Sep 2017 03:50

clinton.hall wrote:what version of CouchPotato are you running? there was a problem with retrieving the year data, but this was fixes some time ago in source.


Sorry for the late reply, I'm running version 0a97ed5a (6/26/2017, 7:29:35 AM).


Return to “Support”