Couch Potato running extremely slow

Get help with Couchpotato
dreni
Junior Member
Posts: 2
Joined: 27 Jul 2012 01:01
Contact:
Status: Offline

Couch Potato running extremely slow

Postby dreni » 30 Jul 2012 01:27

CouchPotato v2 (version: linux - git-e1d7440b -v2) is running very slow on my server. I have Sickbeard, SABnzbd and they are running just fine, but not CouchPotato.

When I run the top command in linux and browse to my CouchPotato server, python is taking all my CPU, the CPU level rises to around 98% and %MEM level 11.8.

Any thing I could do to make CouchPotato run faster?

Thanks in advance

bengalih
Senior Member
Posts: 334
Joined: 14 May 2012 23:39
Contact:
Status: Offline

RE: Couch Potato running extremely slow

Postby bengalih » 30 Jul 2012 03:52

try a completely fresh reinstall.

ensure you are on python 2.7.x

dreni
Junior Member
Posts: 2
Joined: 27 Jul 2012 01:01
Contact:
Status: Offline

RE: Couch Potato running extremely slow

Postby dreni » 30 Jul 2012 14:16

Hi thanks for you answer, I had python 2.6.6 so I installed 2.7.2 instead. Now when I run python CouchPotato.py I get: Aborted and nothing.
Strange. Do I need to do anything else than installing and doing a update-alternatives and choosing python 2.7.2?

bengalih
Senior Member
Posts: 334
Joined: 14 May 2012 23:39
Contact:
Status: Offline

RE: Couch Potato running extremely slow

Postby bengalih » 31 Jul 2012 00:08

I don't have a linux box on hand right now...but I believe as long as you are on 2.7.x python I believe that is all you should need.

Try to do a fresh install of CP (remove what is in your personal/home couchpotato directory).

Make sure you are actually calling the correct version of python when you run it. You can append --debug to the end of couchpotato.py to get more logging.

If it isn't even launching the app seems like something is wrong outside of CP. We at least need to see some debug output.

longinusbane
Junior Member
Posts: 5
Joined: 05 Jul 2012 02:15
Contact:
Status: Offline

RE: Couch Potato running extremely slow

Postby longinusbane » 01 Aug 2012 16:48

bengalih wrote:I don't have a linux box on hand right now...but I believe as long as you are on 2.7.x python I believe that is all you should need.

Try to do a fresh install of CP (remove what is in your personal/home couchpotato directory).

Make sure you are actually calling the correct version of python when you run it. You can append --debug to the end of couchpotato.py to get more logging.

If it isn't even launching the app seems like something is wrong outside of CP. We at least need to see some debug output.



just a stupid question, i'm having a similar problem on windows... and i just realized that pythonpath is not set amongst my environment variables. could this be a problem? i didn't pay attention to this in the past since couchpotato would at least run.


Return to “Support”