Issues with URLs via mod_proxy

Get help with Couchpotato
a2s1971
Junior Member
Posts: 2
Joined: 03 Aug 2012 19:31
Contact:
Status: Offline

Issues with URLs via mod_proxy

Postby a2s1971 » 03 Aug 2012 19:41

Hi,
I have been using CP1 and qouch for about six months now, and have followed the wonderful instructions here http://wiki.ivonet.nl/display/LINUX/Qou ... +sickbeard to configure one single TLD for sabnzb, couchpotato and sickbeard.

I have now upgraded to CP2, which is nothing short of brilliant. However, it does not behave the same as CP1 through the proxy. I am getting a page not found error on qouch which seems to indicate that there is some sort of URL hardcoding going on in CP2.

To summarise.

1. CP1 works perfectly through the proxy
2. CP2 does not work through the same proxy
3. CP2 works perfectly in qouch if I access it directly at 10.0.1.xxx:5050

I have a feeling that the API urls are not relative in CP2, is that possible?

This is a minor issue for me, but it would be great to see it fixed.

I've made a small donation for the wonderful work being done so far. Thank you (8U957677PF302411M)

bengalih
Senior Member
Posts: 334
Joined: 14 May 2012 23:39
Contact:
Status: Offline

RE: Issues with URLs via mod_proxy

Postby bengalih » 05 Aug 2012 17:32

Under Settings > General (with "show advanced settings checked") did you enter the URL Base option?

a2s1971
Junior Member
Posts: 2
Joined: 03 Aug 2012 19:31
Contact:
Status: Offline

RE: Issues with URLs via mod_proxy

Postby a2s1971 » 05 Aug 2012 19:33

Yes, I change that setting to match my original CP1 configuration. Then I also change the proxy port to 5050.

It is the API calls that are failing. I believe they are failing because they are not relative address. Will do some more research.


bengalih wrote:Under Settings > General (with "show advanced settings checked") did you enter the URL Base option?


Return to “Support”